Support: Miro Web Clipper
Item logo image for Miro Web Clipper

Miro Web Clipper

miro.com
Featured
3.4(

103 ratings

)

42 support issues

For additional help, check out the developer's support site.

  • All
  • Questions
  • Suggestions
  • Problems

Ivan Avs

May 13, 2024

very necessary

Add please the ability to add an image when you right-click on it - "save image to miro"

Xavier Coiffic

Apr 3, 2024

It's not working

the web clipper is not working, keep asking me to log in while I'm already logged in.

Max Ramaciotti

Jan 30, 2024

Not working, error message saying no account, while logged in

It seems that I do not have a Miro account, Please login with an another profile
in another tab I am logged in with my miro account, that is associated to my Microsoft profile

Nathan Groves

Nov 14, 2023

Miro web clipper not working

Is greyed out, many comments, please fix

alexatprojects

Apr 13, 2023

web clipper

Will someone please fix this asap!

ThinkFirst Marketing

Apr 3, 2023

Miro customer and until now, a fan

It's very disappointing that no one is addressing the greyed out logo issue for the web clipper and the overall lack of configuration in the clipping app - "Oops.. I do have a Miro account and don't need to log in with another profile'

Ruba Katrib

Feb 1, 2023

Greyed out extension

It doesn't work - I have tried to remove and readd and reload, nothing works.

James Kirkwood

Dec 22, 2022

Web Clipper

The extension is greyed out. When I hit the upload symbol on the left of my miro board it tells me to install the extension. The extension is already installed by greyed out. I have removed it and reinstalled but it is still greyed out.

Kai Fünfstück

Oct 4, 2021

Web Clipper doesnt´t work with entire page function

Web Clipper doesnt´t work with entire page function. Is there any idea to fix this?

Hyggehaus Home Decor

Aug 8, 2021

Miro chrome extension - team not showing up

Hi, I have been using Miro for about a month with no problems, but the chrome extension is no longer working - its like it isnt connecting to my Miro account as the "team" drop down is not showing up. I have MIRO opened in the background and have tried changing some settings to make it work, as well as uninstalling and reinstalling. Please help

Google apps